Jump to content

The location of the transistors of the coils on the ECU board?


Alla
 Share

Recommended Posts

Hi guys. I'm having a problem with the 2002 avalon. I have misfires on cylinders 3 and 6. The coils run out, even when I connect them outside the engine forcing a spark on the spark plug; (as I understood it, the control transistor burned out (I found the insulation melted on the wiring harness) but burned out strangely, the spark remained and the coils were warming up. I bought a second block with the same marking that I have, but it does not start because of the immobilizer ... Or rather, it is not in my avalon (immo), a simple key. The search for me was thrown into the forum, but along the way there were various ways to fix the missing ignition. This is not my case...Therefore, please guys: I can’t determine the control transistor for these coils. I took a soldering iron., a tester .... But alas, my knowledge of mechanics will not allow me to repair it, I know a little electronics. Does anyone have a photo of the board showing the transistors clearly?
 Thanks for reading and here is a link where possible there is a benefit for those looking for the cause of misfire (interesting rare case)

 http://danthefixitman.org/2001-toyota-avalon-po171-bank-1-lean-and-po300-po301-po303-po305-misfires-fixed/

Link to comment
Share on other sites


10 hours ago, Toyota Owners Club said:

Did you ever find the transistors you were referring to?

Hi. No, I didn't need it before, but I erased a video on how they are being replaced. however, on other ECUs they are clearly large and this complicates the process. For me, armed with a tester on an ohmmeter, I searched for the control contact to the coil connector (trigger). after on the board I found this contact and looked through the track to the capacitor "c909" from it rings on all emitters of large transistors (I assumed that it is the large ones that participate in the signals of the coils t 928, t937, t 938, t939, t940, t941), and here here I am in a stopper. and this picture is on both ECUs.

Link to comment
Share on other sites

On 9/13/2021 at 7:47 AM, Toyota Owners Club said:

you could look on Lexus Owners Club as this is a common failure item and capacitor replacement has been discussed in detail before

Thanks for responding, the reason for the capacitor is not entirely clear, I thought it was a transistor, but it doesn't matter. If you have a link to this discussion, then it will be great to ask for it, to restore the native ECU. however, I went further and this is what I came to: I removed the upper console from the donor lexus es 300 and lowered the steering wheel to the pedals) unwound the cable braids from the immo amplifier unit, remembering the designers, pulled all 3 wires (4 wire went to the ground, this is easy) pulled through to the connectors and came to the computer. And then voila! All this beautiful garland needs to be transplanted and my avalon, but... need a chip  key .... I ordered it, I'm waiting. Then with a key and crossing my fingers I will try to register it as a man in the video; ) :

 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership