Sign in to follow this  
audoic

95 camery wiper motor problems

Recommended Posts

95 camery, I stored it for the winter,I didn't need it. every thing worked, now after taking it back out, when I start it or turn the key on the wipers won't shut off. I unpluged the motor a few times it did't help and then I tried taking the fuse out hoping to reset it and that didn't work. any sugestions on what it could be. switch or handle, wiper motor or relay...

Thank you Ken / audioc

Share this post


Link to post
Share on other sites
 
95 camery, I stored it for the winter,I didn't need it. every thing worked, now after taking it back out, when I start it or turn the key on the wipers won't shut off. I unpluged the motor a few times it did't help and then I tried taking the fuse out hoping to reset it and that didn't work. any sugestions on what it could be. switch or handle, wiper motor or relay...

Thank you Ken / audioc

Ken,

I doubt it is the motor since the wipers work.

Since the vehicle was stored I would start by trying to trace the wires in question. Mice seem to love eating insulation off of wires when vehicles are stored. A simple short in the switch circuitry would cause this.

Check relay, is it stuck on or is it getting a signal telling it to stay on?

If getting a signal then you will have to trace that signal back to see if switch is faulty.

Good luck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this