Gus

2017 sienna le awd - awd check light on & cruise control not working

Recommended Posts

I have 40,000 miles. Went in for service and new tires. Told I need alignment and brake fluids changed although pads ok, Then dealer could not align correctly, needed front camber bolts. Brought back next day and done. Rear wheels still a bit out of spec by about 1.4. Dealer said normal no problem. Went home, started van next morning now awd check light on. Also cruise control not working. Back to dealer, they check it and tell me it probably a rat chewed a wire inside engine. 80 hours of work and $3,000 to pull engine. Most likely original part not faulty. Advised to call insurance company to pay through comp on policy. Anyone experience anything like this? Thanks.

Share this post


Link to post
Share on other sites

There are no wires INSIDE the engine. There is a wiring harness in the engine compartment. Should not have to pull the engine to check it. I suspect the rat they speak of may be working at that shop. Get another diagnosis somewhere else. You only need an alignment if the cars pulls one way or another or if the tires show uneven wear. Don't spend anymore money there go elsewhere.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...