Sign in to follow this  
Imie Salcedo

Toyota shutdown

Recommended Posts

I have 2002 Camry V SERIES with automatic transmission and 204k miles.

When I run camry in the morning, it runs normal for about 30 minutes. After 30 minutes, when temperature gauge is at middle, car runs normal in all gears. However, at stop light car hesitates when car has run for 30 min and finally car shuts down. When I restart hot car, check engine light shows and engine kicks but does not start at all. I wait for 4 hours and let it "cool down" and car starts and runs normal. When car is cold all gear works normal. No gear shifting issue or noise. When hot, no gear noise but car become hesitant to start at stop light and stops all together with check engine light.

This car was not used for about 3 months but ran fine. This camry has many replaced parts (new PCV valve, cleaned throttle body, new distributor cap+spark plugs+distrib cables, newer timing belt+oil pump, new radiator, fuel pump, barke, battery). Most parts changes in last year or so and no pproblem until now. Transmission oil level is normal when car running in park on level ground and transmission oil looks norma (no burnt smell and pinkish)

Is it transmission issue or engine/engine control issue?
How do I diagnose the problem and fix it?

Thanks in advance for your help. I am newbie but enthusiastic and will try suggestions.

Thanks,
Ben

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this