Sign in to follow this  
Joe Burdock

compression issues

Recommended Posts

Hello, I'm new to the forum and the matrix. I Have an 04 with 160,000miles on it. I'm close to taking it to the mechanic but wanted to see if I could get some helpful advice here.

Well I've only had it a month or so, it's always had a rough idle and ran rough at high speeds but I've been working on it and it had been getting better. The engine gave me a "miss in cylinder 3" code so I changed spark plugs checked some things and finally did a compression test. The result where food in cylinder 1&4, but #3 had no compression wet or dry and #2 would tick up to 50psi on each crank then fall to zero.

From what I'm reading, it sounds like a head gasket but there are no other symptoms. No oil in the coolant. No overheating. I know it sat for a while I'm wondering about stuck valves? I'm new to gas cars (I have a diesel rabbit '81)so I don't completely understand them though I'm learning quickly. Any advice would be appreciated. I'm been looking for a leak down tester but if it were a problem beyond the valve cover of probably take it to a shop anyway. Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this