Ganno

Regular Member
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Ganno

  • Rank
    Newbie

Profile Information

  • Toyota Model*
    Camry xle
  • Toyota Year*
    2008
  • Location*
    Minnesota (MN)
  1. Hit a dead deer about a year ago and vsc and traction control lights came on. Eventually ran fine and lights went off till a few days ago. Recently the radio died and the lights came on. Car would not start. Jumped it and it restarted but it sputtered and I shut it off. Replaced the battery. Started and drove 60 miles or less. Radio died again, lights came on and engine sputtered and sounded bad. Car is now parked, won't start or even go into gear unless you disconnect battery, wait a while and then re-connect. At shop now waiting for diagnosis but would like to avoid troubleshooting and fix myself if possible. Thanks for any ideas.
  2. Hit a dead deer about a year ago and vsc and traction control lights came on. Eventually ran fine and lights went off till a few days ago. Recently the radio died and the lights came on. Car would not start. Jumped it and it restarted but it sputtered and I shut it off. Replaced the battery. Started and drove 60 miles or less. Radio died again, lights came on and engine sputtered and sounded bad. Car is now parked, won't start or even go into gear unless you disconnect battery, wait a while and then re-connect. At shop now waiting for diagnosis but would like to avoid troubleshooting and fix myself if possible. Thanks for any ideas.